#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "data-src-l="(.*)""
Local $sString = "<div id="ProductImages" class="noscript">" & @CRLF & _
" <ul> " & @CRLF & _
" <li>" & @CRLF & _
" <a href="/WebRoot/products/8020/80203122/bilder/80203122.jpg">" & @CRLF & _
" <img itemprop="image" alt="Jesus Remember Me - Taize Songs (2CD)"" & @CRLF & _
" src="/WebRoot/AsaphNL/Shops/asaphnl/5422/8F43/62EE/" & @CRLF & _
" D698/EF8E/4DEB/AED5/3B0E/80203122_xs.jpg"" & @CRLF & _
" data-src-xs="/WebRoot/AsaphNL/Shops/asaphnl/5422/8F43/62EE/" & @CRLF & _
" D698/EF8E/4DEB/AED5/3B0E/80203122_xs.jpg"" & @CRLF & _
" data-src-s="/WebRoot/products/8020/80203122/bilder/80203122_s.jpg"" & @CRLF & _
" data-src-m="/WebRoot/products/8020/80203122/bilder/80203122_m.jpg"" & @CRLF & _
" data-src-l="/WebRoot/products/8020/80203122/bilder/80203122.jpg"" & @CRLF & _
" />" & @CRLF & _
" </a>" & @CRLF & _
" </li>" & @CRLF & _
" </ul>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")