const regex = new RegExp('(<a.*?href="[a-z0-9]+//.*?">.*?</a>)|(<a href="http://site.ru" class="link_external"><span class="link_text">Заголовок</span></a>)', 'g')
const str = `dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href="/dwdw.php/">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
<a href="http://site.ru" class="link_external"><span class="link_text">Заголовок</span></a>
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href="fdwdwdwd//dwdw.php">dwdqwdqwd</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}