$re = '~(\+[375][0-9]{9,14})~';
$str = '+304343434343434';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);