$re = '/^(?!(?:127)$)\d{3}/m';
$str = '321
123
127';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);