#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[if(.*?)\][\s]*?(.*)[\s]*?\[\/if\]"
Local $sString = "[if var == true]" & @CRLF & _
" [- success -]" & @CRLF & _
"[/if]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")