#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)Address\s:\s(.*)"
Local $sString = "Voice Mail Message: Double click on the attachment to play the voice mail file." & @CRLF & _
"" & @CRLF & _
"Date:" & @CRLF & _
"12/01/2014 01:28:36 PM" & @CRLF & _
"" & @CRLF & _
"Number:" & @CRLF & _
"800-123-4567, JOHN SMITH" & @CRLF & _
"" & @CRLF & _
"CallerID:" & @CRLF & _
"123-456-7890, JANE DOE" & @CRLF & _
"" & @CRLF & _
"Destination:" & @CRLF & _
"Voice Mail" & @CRLF & _
"" & @CRLF & _
"File Duration:" & @CRLF & _
"00:00:37" & @CRLF & _
"" & @CRLF & _
"======================" & @CRLF & _
"" & @CRLF & _
"Name : Jane Doe" & @CRLF & _
"" & @CRLF & _
"Address : 123 Fake Street , Miami , Florida " & @CRLF & _
"" & @CRLF & _
"Phone : 123-456-7890" & @CRLF & _
"" & @CRLF & _
"Ye, my name is Jane Doe. I own the property at 123 Fake Street , Miami , Florida. You sent me a couple of postcards. Let me know if you're interested in making an offer. it's a single family home.3 bedrooms, 2 baths. Has a single efficiency in the back, that's an additional rental income." & @CRLF & _
"" & @CRLF & _
"Again, Jane Doe and that's 123 Fake Street and my phone number is 123-456-7890. Thanks !" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")