using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"tester\|\|\|\|(.*?)~";
string input = @"tester||||123123+++123+++123123~~~~";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}