re = /(?<!\S)[A-ZÄÖÜß][a-zA-ZäöüßÄÖÜẞ]*(?:\s+(?:[A-ZÄÖÜß][a-zA-ZäöüßÄÖÜẞ]*|[+()&]))*\s+(?:Hard|Cars)\b/m
str = 'I like Apple Bananas And Cars. building houses Might Be Salty + Hard said Jessica.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end