import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(\\s*[^\\][\\s\",]+),";
final String string = "[\"teads.tv, 15429, reseller, 15a9c44f6d26cbe1 \",\"video.unrulymedia.com,367782854,reseller\",\"google.com, pub-8173359565788166, direct, f08c47fec0942fa0\",\"google.com, pub-8804303781641925, reseller, f08c47fec0942fa0 \"]\n\n"
+ "[\" , 15429, reseller, 15a9c44f6d26cbe1 \",\"video.unrulymedia.com,367782854,reseller\",\"google.com, pub-8173359565788166, direct, f08c47fec0942fa0\",\"google.com, pub-8804303781641925, reseller, f08c47fec0942fa0 \"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}