re = /<\?=((?:(?!\?>).)+)\?>/m
str = '<?=$user->getName()?> - <?=$office->getName()?>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end