$re = '/^.+version(.*) character file\.([\n\r]+)(\d+)([^\(]+) \([^\d]+( \d+),.+\n\s+.+as a(.+) on.+\n\s+(?:Was.+One\.\n)?((?:.|\n)+[!.])\n(?:.|\n)+\((\d+)(?:.|\n)+$/';
$str = ' Dungeon Crawl Stone Soup version 0.16-a0-3667-g690a316 (webtiles) character file.
462 8Escape the Ruffian (level 6, -2/47 HPs)
Began as a Bearkin Transmuter on Jan 31, 2015.
Slain by an orc
... wielding a +0 trident
(3 damage)
... on level 4 of the Dungeon.
The game lasted 00:28:53 (3698 turns).
8Escape the Ruffian (Bearkin Transmuter) Turns: 3698, Time: 00:28:53';
$subst = "Version:$1\nScore: $3\nName:$4\nCharacter:$6\nLevel:$5\nCause of Death/Victory: $7\nTurns: $8";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;