package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^U(?:AA|AB|BA|BB|CC|CD|EA|FA|GA|HA|IA|JA|AE|CE|GE|FB|JB|GB|HL|IL|JL)[E|U|W]E(?:DN|AZ)\d{2,2}\d\d{8,8}$`)
var str = `UCCUEDN15000003676`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}