re = /^[a-zA-Z]+[^@]*@[a-zA-Z]+[^@]*\.[a-zA-Z]{2,}[^@]*$/
str = 'test_test.test@test.test'
# Print the match result
str.match(re) do |match|
puts match.to_s
end