import re
regex = re.compile(r"\\(?P<command>(re)?newcommand)\{(?P<name>\\\w+)\}(\[(?P<num>\d+)\])?\{(?P<definition>.+)\}", flags=re.UNICODE)
test_str = "\\newcommand{\\bfm}[1]{\\mathbf{#1}}"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")