using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Date (MM DD YYYY)";
string input = @"
'/^((0?[1-9]|1[012])[- /.](0?[1-9]|[12][0-9]|3[01])[- /.](19|20)?[0-9]{2})*$/'";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}