const regex = /^(?<!\n)(\[)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<!\\n)(\\[)', 'm')
const str = `[some link](somepage.md)
(?<!a)b`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}