const regex = /\b(\w+)=((?:\s*[^=>]+\b(?![=]))+)?(\s+|\/?>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w+)=((?:\\s*[^=>]+\\b(?![=]))+)?(\\s+|\\\/?>)', 'g')
const str = `<tool id=2 code=abc description=my description end here my_levels=\$15,000/\$30,000 individual_level= amount=0 status= my_code=P my_date=2017-02-21T00:00:00 points= />
<tool id=2 code=abc description=my description end here my_levels=\$15,000/\$30,000 individual_level= amount=0 status= my_code=P my_date=2017-02-21T00:00:00 points=3 />
<tool id=2 code=abc description=my description end here my_levels=\$15,000/\$30,000 individual_level= amount=0 status= my_code=P my_date=2017-02-21T00:00:00 points=3/>
<tool id=2 code=abc description=my description end here my_levels=\$15,000/\$30,000 individual_level= amount=0 status= my_code=P my_date=2017-02-21T00:00:00 points=3></tool>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}