re = /\w+\.\w+(?=$|[\/?#])/m
str = 'https://www.google.com/images
google.com
https://google.com
dev.google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end