re = /^(?!\.)[\w0-9\.]+(?<!\.)@+(?<!\.)[\w0-9\.]+\.\w{1,3}(\s*<[^>]+>)?$/m
str = '.test@test.be
.test.test@test.be
test.test@test.be
|test.test@test.be'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end