# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<!--(?:(?!<!--|-->).|(?R))*-->"
test_str = ("Remove comments from some generated HTML which can be invalid with nested comments\n"
"==================================================================================\n\n"
"I would like to remove HTML comments from some generated content.\n"
"If I use the regex `/<!--(.*?)-->/` (ungreedy with the `?`) then it works for most cases such as this example:\n\n"
"```html\n"
"<!-- <h1> test </h1> --> not remove <!-- <h1> test 2 </h1> -->\n"
"```\n\n"
"It gets rid of the `<h1>` tags and leaves the \"*not remove*\" as desired.\n\n"
"But **if the comments are nested**, then it will not handle it properly as it will leave the last comment closing tag `'-->'`. The workaround would be to use a greedy pattern, but in this case it will not work for the first case, with multiple comments.\n\n"
"Example of nested comments (I know it's not valid HTML, but it's the backend which is generating it):\n\n"
"```html\n"
"text <!-- something <!-- <p> test </p> --> need remove -->\n"
"```\n\n"
"I've tried to find a solution, but I don't know how to solve this. Has anyone an idea how to handle it?\n\n"
"<!-- multiline\n"
"comment -->\n\n"
"<!-- <footer>Footer with\n"
" nested <!-- comment -->\n"
" on several lines.</footer>\n"
"-->")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.