$re = '/^(?:\*|\*?\p{L}+(?:\h+\p{L}*)*+\*?)$/m';
$str = 'Accepted strings:
*city
*cit *
*
*city one
Not accepted strings:
**
*!@
%^&*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);