const regex = /(.*)\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\n', 'gm')
const str = `https://www.youtube.com/watch?v=FQnn273XB4E&lc=UgyfyHQ4V7U1jyXgVzB4AaABAg
https://www.youtube.com/watch?v=uWRrwchNC9A&lc=Ugz81htqjuaNrfuJAPx4AaABAg
https://www.youtube.com/watch?v=QtTxHy40jQU&lc=UgyOb1zbdQHOAlloKEB4AaABAg
https://www.youtube.com/watch?v=qwkI6pD-feU&lc=UgzV_Bqwun7PI5Q5z6d4AaABAg
https://www.youtube.com/watch?v=gX9xThqkzsA&lc=UgwHE-IKAEzwG-ql1Hh4AaABAg
https://www.youtube.com/watch?v=Xm_Vp5BRWGg&lc=Ugz08iGMIFhvwO8WNFd4AaABAg
https://www.youtube.com/watch?v=7s3xOV_CaJA&lc=UgzjC8v7vAxHSGK1As54AaABAg
https://www.youtube.com/watch?v=TW5NIHOl38A&lc=UgwJEzBEnz5kUmsw24d4AaABAg
https://www.youtube.com/watch?v=tqdKdJck7Ls&lc=UgybUtTeDJfX8ADm7S54AaABAg
https://www.youtube.com/watch?v=0FVEIXv8IXE&lc=UgxkRhiqVh52s_najwF4AaABAg
https://www.youtube.com/watch?v=ixw7VtXH56U&lc=UgwukKc4T7vKdVrtp754AaABAg
https://www.youtube.com/watch?v=TMagfdT-kTA&lc=Ugz0_0C8LVJgnDRqniR4AaABAg
https://www.youtube.com/watch?v=2OrmF-hJZwE&lc=UgyJpZNH5pV2nCgPuzp4AaABAg
https://www.youtube.com/watch?v=rcnpeIZQ6I4&lc=UgzOSEDdX6V5tWlLE7l4AaABAg
https://www.youtube.com/watch?v=GzI7hhtvmog&lc=Ugwrw4rdc9aWPRwRTuF4AaABAg
https://www.youtube.com/watch?v=Imh1VWWk8BM&lc=UgyQXkLvzCSKfIVL_uF4AaABAg
https://www.youtube.com/watch?v=WTsi5z-l8F4&lc=UgzpZGnnPYzGlr0bA6h4AaABAg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}