$re = '/((?<=href="\/)(.+(?=\.(doc|pdf)))|(?<=src=")((http|https).+(?=\/(v2|userfiles)\/)))/';
$str = 'href="http://www.mataderomadrid.org/v2/userfiles/WEB_ESP_LINEAS%20DE%20PROGRAMACION%20DE%20MATADERO_29_01_19.pdf"
href="/userfiles/WEB_ESP_LINEAS%20DE%20PROGRAMACION%20DE%20MATADERO_29_01_19.pdf"
href="/userfiles/WEB_ESP_LINEAS%20DE%20PROGRAMACION%20DE%20MATADERO_29_01_19.doc"
href="/this/is/valid"
href="/this/another/valid/link.html"
src="/userfiles/image.png"
src="/userfiles/image.jpeg"
src="/userfiles/image"
src="http://www.mataderomadrid.org/v2/xxx.jpeg"
src="http://www.mataderomadrid.org/userfiles/xxx.jpeg"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);