#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi).*(?=loc).*(?=act).*(?=dosar)"
Local $sString = "                     <h3 class="asset-title"> <a href="https://www.primariapn.ro/anunturi/-/asset_publisher/d8F7ynMHzZPK/event/id/3700162?redirect=https%3A%2F%2Fwww.primariapn.ro%2Fanunturi%3Fp_p_id%3D101_INSTANCE_d8F7ynMHzZPK%26p_p_lifecycle%3D0%26p_p_state%3Dnormal%26p_p_mode%3Dview%26p_p_col_id%3Dcolumn-2%26p_p_col_count%3D1"><img alt="" src="/ppn321-theme/images/common/date.png"> Actualizare dosare locuințe</a> </h3>" & @CRLF & _
                "                     <div class="asset-content">" & @CRLF & _
                "                        <div class="asset-summary">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")