$re = '/(?<=BRAND~\*).*?(?=\*~)/m';
$str = 'BRAND~*HP*5250*RAM128*GPUAMD7990*~
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);