$re = '/^[A-Za-z0-9+/]*={0,2}$/m';
$str = 'sdfkjhlkj/++/h=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);