re = /([a-zA-Z|tT28]+-\d+[zZ]?[eE]?)(?:-pt)?(\d{1,2})?/m
str = 'ABP-420-pt1.mp4
ABP-420-pt2.mp4
ABP-420.mp4
ABP-420.1080p.mp4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end