$re = '/(?<=/)([0-9]{1,2}[\*]*[GM][\+]{0,1}?)\1+/';
$str = 'AA/8G+8G+8G+8G/WITHOUT *
AA/8*G+8*G+8*G+8*G/WITH *
AA/8G+8*G+8*G+8*G/MIXED, THIS IS NOT SUPPORTED YET
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);