$re = '/(?!")({{.*?}})/m';
$str = 'Lorem ipsum {{ var }} dolar epsum <a href="{{ var5 }}">solar</a> hello goodbye. {{var3}} var {{ var2 }}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);