$re = '/\+?\b\d+(?!\S)/m';
$str = ' 18 mai 2007 +1234 43543
abc+33444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);