use strict;
my $str = '\\\\p8files\\MVP\\Inbound\\2023\\202310\\20231016\\BillingProvEntityFix1016.xlsx
\\\\p8files\\MVP\\Inbound\\2023\\202310\\20231016\\BillingProv_MVP_EntityFix1016.xlsx
\\\\p8files\\MVP\\Inbound\\2023\\202310\\20231016\\BillingProv_MVP_Entity_MissingFix1016.xlsx';
my $regex = qr/(?=[^\\]*MVP[^\\]*$)(?!.*Missing).*\.(?:csv|txt|xlsx?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}