import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\d]{1}x[\\d]{1}|[\\d]{2}x[\\d]{2}|[\\d]{3}x[\\d]{3}|[\\d]{4}x[\\d]{4}";
final String string = "1dhDghbh2556x44Hjjitf\n\n\n"
+ "234-567\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}