#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.* .* )[A-Za-z ]*$"
Local $sString = "Hello" & @CRLF & _
"Hello World" & @CRLF & _
" Spaceinbeginning" & @CRLF & _
"Spaceatend " & @CRLF & _
" Two spaces" & @CRLF & _
"Two spaces " & @CRLF & _
"Two spaces"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")