const regex = new RegExp('\\b\\w*?([a-z])\\1\\1\\w*\\b', 'gmi')
const str = `AAAAA likes apples, but BBBBB likes bananas. Their phone numbers are ffffr and ggggh.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}