package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/([^/]+)$`)
var str = `https://www1.abc.com/aaa/72566-finance
https://www1.abc.com/aaa1/725-z2
https://www1.abc.com/aaa2/75-z3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}