re = /(@Project:|Feature:|Scenario:|Given|When|Then|#Task:) ?(.+?)(?=[\s\S](@Project:|Feature:|Scenario:|Given|When|Then|#Task:)|$)/m
str = '@Project:FOOPROJ
Feature: Some text
Scenario: Lorem
Given Lorem Ipsum
When Lorem Ipsum
Then Lorem Ipsum
Given Lorem Ipsum
When Lorem Ipsum
Then Lorem Ipsum
#Task: Lorem Ipsum
Tasks\'s not getting picked up
#Task: Task 2
#Not working
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end