use strict;
my $str = 'A B C D E';
my $regex = qr/(?<=\s)\s/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";