using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=::)(?<stuff>.*?)(?=::)";
string input = @" 14 12:59:18 138.127.77.69 Jun 14 15:57:24 etwk-fs04rpl-01: some-host-01: 00000011.003faf5b 08f59080 Mon Jun 14 2021 15:57:23 +00:00 [kern_audit:info:2084] 0000000000000000 :: some-netapp-cluster:ssh :: 147.25.131.179:37666 :: some-netapp-cluster:admin :: Login Attempt :: Error: Authentication failed.
Jun 17 18:14:45 138.127.77.69 Jun 17 21:12:45 etwk-fs04rpl-01: etwk-fs04rpl-01: 00000011.00416057 0920009f Thu Jun 17 2021 21:12:43 +00:00 [kern_audit:info:2084] 8503e80000249b79 :: some-netapp-cluster:ontapi :: 138.127.78.36:58828 :: some-netapp-cluster:admin :: <netapp xmlns=""http://www.netapp.com/filer/admin"" version=""1.0""><snapmirror-update><destination-volume>opengrok</destination-volume><destination-vserver>some-netappsvm</destination-vserver><max-transfer-rate>0</max-transfer-rate></snapmirror-update></netapp> :: Pending: ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}