$re = '/\w+\d{8}/m';
$str = '3hkec
serenade1412
MartinN00501791
marcoch66187747
misschriss_L
Jesscb2019
jason7791434699
Yellows48674095
balala08379047
CurtisChan17
time_mueller
JackHo85688674
Kim001111
Petamol
ppll29290443
pudupurin
Man98472040
Dyrone11
crush309
Tung35413455
DingDingchan316
eddiewo92726914
EchoWaiWong1
sum38034379
PipiCheng1
mineeewtx
bebebetarochan
sdjx88
lammeiheungbaby
kitashawa
NLKK0425
LamYuCheung2
CheungKaylie
srrst_
KwongSuzanne
jKtU3rcSCSbPOdb
Sourlem54344884
pepoopie
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);