re = /(?<nn>(?!und)[^\/,&;]+)(?:,\s?+)(?<vn>(?1))(?:\/|&|;|und|$)\s?/m
str = 'Oidtmann-van Beek, Jeanne und Oidtmann, Peter'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end