$re = '`(([0-9]{4})(-[0-9]{2}){2})`m';
$str = '2022-08-22T03:02:20+0700';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);