$re = '/(?<=\p{Ll})(?=\p{Lu})(?=.*\s[sS]\d{1,2}[eE]\d)/m';
$str = 'FooBar-tooGGG1 - s01e01 - (HW) - SomeText.mp4';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;