$re = '/\b(?<!\.)(?!0+(?:\.0+)?%)(?:\d|[1-9]\d|100)(?:(?<!100)\.\d+)?%/';
$str = '3% 3.5% 0% 0.0% 0.03% 777% 100% 100.13% 99.99% 00.03%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);