re = /^(?=^.{1,10}$)[a-zA-z0-9\!\$\%\&]+(?: [a-zA-z0-9\!\$\%\&]+)*$/m
str = 'This is a sentence
0123456789
0123456789a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end