using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)Director(.*?)Class";
string input = @"[18-Apr-19 05:54 PM] Charliebot#6692
{Embed}
Race Result
http://inssomniak.5gbfree.com/RaceResult/901.html
""Blaine County 24h North""
Director
9Jeremiah9
Class
Classic Sports B
Weather
CLEAR
Laps
7
Start
04/17/2019 18:14:34
Duration
11 minutes
1st
Nolan North
2nd
aharmlesscat
3rd
Subaruken
[18-Apr-19 05:54 PM] Charliebot#6692
{Embed}
Race Result
http://inssomniak.5gbfree.com/RaceResult/902.html
""CRE8 - Mercedes Autodrome""
Director
9Jeremiah9
Class
Modern Muscle
Weather
CLEAR
Minutes
10
Start
04/17/2019 18:30:59
Duration
13 minutes
1st
Subaruken
2nd
Elbererth
3rd
CSP
[18-Apr-19 05:54 PM] Charliebot#6692
{Embed}
Race Result
http://inssomniak.5gbfree.com/RaceResult/903.html
""SCRZ Monte verde""
**Time Attack**
Director
Elbererth
Class
Supers
Weather
CLEAR
Laps
7
Start
04/17/2019 18:46:41
Duration
12 minutes
1st
Elbererth
2nd
Subaruken
3rd
bvneet
[18-Apr-19 05:54 PM] Charliebot#6692
{Embed}
Race Result
http://inssomniak.5gbfree.com/RaceResult/904.html
""LS Gas GP""
Director
9Jeremiah9
Class
Muscle
Weather
CLEAR
Minutes
10
Start
04/17/2019 19:09:06
Duration
12 minutes
1st
Elbererth
2nd
Olli399
3rd
Epic gamer
[18-Apr-19 05:54 PM] Charliebot#6692
{Embed}
Race Result
http://inssomniak.5gbfree.com/RaceResult/905.html
""FISH Plastic Beach""
Director
lodus
Class
Sport Sedans
Weather
CLEAR
Minutes
12
Start
04/17/2019 19:28:29
Duration
15 minutes
1st
Elbererth
2nd
bvneet
3rd
aharmlesscat
[18-Apr-19 05:54 PM] Charliebot#6692
{Embed}
Race Result
http://inssomniak.5gbfree.com/RaceResult/906.html
""Northwick GP Update""
Director
lodus
Class
Testing
Weather
CLEAR
Minutes
12
Start
04/17/2019 19:48:33
Duration";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}