import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*?(\\d+(?:[.]\\d+){3}(?:/\\d+)?)){2}";
final String string = "Deny tcp src dmz:77.77.77.7/61112 dst dmz:55.55.56.57/139 by access-group \"outside_access_in\" [0x8b3ecfdc, 0x0]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}