import re
regex = re.compile(r"^(?:.*?\b((?:25[0-5]|2[0-4]\d|[0-1]?\d?\d)(?:\.(?:25[0-5]|2[0-4]\d|[0-1]?\d?\d)){3}(?:/\d+)?)){2}", flags=re.MULTILINE)
test_str = "Deny tcp src dmz:77.77.77.7/61112 dst dmz:55.55.56.57/139 by access-group \"outside_access_in\" [0x8b3ecfdc, 0x0]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")