re = /(?:https?:\/\/(www\.)?)?[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b([-a-zA-Z0-9@:%_\+.~#?&\/\/=]*)/m
str = 'hello example.com
hello www.example.com
hello http://example.com
hello https://example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end