import re
regex = re.compile(r"(?<=\[@introS\]).+?(?=\[@introEnd@\])", flags=re.MULTILINE)
test_str = "Par suite des contes pseudonymes dont on vient de parler, feu M. John Ballantyne, éditeur $des ouvrages de Walter Scott, a soutenu une discussion avec son confrère de Londres, chacun $d'eux soutenant que son Jedediah Cleishbotham était le vrai Simon Pure. $CHAPITRE PREMIER. $[@introS] C'est aux moines qu'on doit la superstition, $La nuit des préjugés et des erreurs grossières $Qui couvrit si longtemps les siècles de nos pères. $- Je bénis comme vous la bienfaisante main $Qui de tous ces fléaux purgea le genre humain : $Mais sur les moines seuls en rejeter la cause, $C'est à quoi ma raison trop fortement s'oppose. $Je croirais aussi bien que Molly Warburton, $Traversant cette nuit les airs sur un bâton, $Causa l'orage affreux qui gronda sur nos têtes. $Ancienne comédie. $E village auquel le manuscrit du bénédictin donne le nom $de Kennaquhair porte la même terminaison celtique qu'on $trouve dans Traquhair, Caquhair, et d'autres mots com $posés. Le savant Chalmers\" prétend que le mot quhair $- signifie les sinuosités d'une rivière; et les nombreux $détours que fait la Tweed près de ce village rendent l'étymologie $assez vraisemblable[@introEnd@]. [@introS]Longtemps Kennaquhair a été céièbre par le $superbe monastère de Sainte-Marie, fondé par David I\", roi d'Écosse, $sous le règne duquel s'élevèrent aussi les couvents non moins riches $de Melrose, de Jedburgh et de Kelso. Les domaines considérables $que ce monarque accorda à ces divers établissements religieux lui $firent décerner le titre de saint par les moines qui écrivirent les chro $niques de ce temps, et dire par un de ses descendants appauvris, - $qu'il avait été un triste saint pour la couronne. ' $On peut cependant présumer que David, prince aussisage que pieux, $ne fut pas déterminé seulement par des motifs de religion à ces grands $•_/ $[@introEnd@]. [@introS] Google est fier de travailler en partenariat avec des bibliothËques ‡ la numÈrisation des ouvrages appartenant au domaine public et de les rendre $ainsi accessibles ‡ tous. Ces livres sont en effet la propriÈtÈ de tous et de toutes et nous sommes tout simplement les gardiens de ce patrimoine. $Il s'agit toutefois d'un projet co˚teux. Par consÈquent et en vue de poursuivre la diffusion de ces ressources inÈpuisables, nous avons pris les $dispositions nÈcessaires afin de prÈvenir les Èventuels abus auxquels pourraient se livrer des sites marchands tiers, notamment en instaurant des $contraintes techniques relatives aux requÍtes automatisÈes [@introEnd@]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")