const regex = /(?<=\|.*)\|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\|.*)\\|', 'gm')
const str = `контура|силуэта|абриса|профиля
контурам|силуэтам|абрисам|профилям
контурами|силуэтами|абрисами|профилями
контурах|силуэтах|абрисах|профилях
контуре|силуэте|абрисе|профиле`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);